Today is...
Tuesday, September 24, 2019
Welcome to Control.com, the global online
community of automation professionals.
Featured Video...
Featured Video
A demonstration of EtherCAT control of linear motors using the CTC EtherCAT master.
Our Advertisers
Help keep our servers running...
Patronize our advertisers!
Visit our Post Archive
ACRNET Card for MARKV LED Diagnostic
After a voltage disturbance in the electrical Network, the computer used to monitor the MARK V system didn't start again

We have a computer to monitor the parameters in the GE MARKV Control System, and after a voltage disturbance the PC was found OFF even when the led status of Hard Disk was blinking.

After an initial troubleshooting, the +5 volts stage in the power supply wasn't working, so it was replaced. Meanwhile the IT team tried to make a image of the disk but only a copy was made. After the power supply was replaced, the software didn't start, and the IT team overwrite the autoexec.at and config.sys files. The program starts but there is no valid data from the controller.

The network card is a Network Interface corp PCARC-ACT with a BNC connector.

Question: The led doesn't stop blinking and is that correct?
We changed the coaxial cable, the Terminal T connector and the same legend- No valid data.

Is possible to check the Network card without having another one at place?

The network Card has 7 as node address, is that correct?

I will appreciate comments about this case.

1 out of 1 members thought this post was helpful...

Terminalman,

Wow. It's interesting that you didn't say the computer to monitor parameters in the GE Mark V system was a GE-supplied <I> (running IDOS and MS-DOS) or a GE Mark V HMI (running some version of MS-Windows and CIMPLICITY and TCI (a background service necessary for the computer to be able to use the ARCnet card). Is it some other supplier's "computer to monitor Mark V parameters"?

If you can tell us just a little more about the computer and who supplied it (programmed/configured it) we might be able to help.

If it's a GE-supplied <I>, the autoexec.bat and config.sys files are unique to each <I> computer and if they were "overwritten" what were they overwritten with?

My guess is whoever is doing the troubleshooting is going after the "easy" stuff--the hardware (the coaxial cable; the BNC tee connector; etc.). That's more than likely NOT going to be the problem.

As for diagnostics on the ARCnet card, you need to use your preferred World Wide Web search engine and see if you can find the manufacturer's website and see if any documentation is available there which might help you.

But, there are too many questions and possibilities depending on who supplied and programmed and configured the computer. The computer would have to have an ARCnet card of some kind to be able to talk to the Mark V (or some kind of ARCnet-to-Ethernet driver (though GE doesn't supply those kinds of HMIs--to my knowledge they never have).

Tell us more about the PC and we can try to help.

>Tell us more about the PC and we can try to help.

Thank you for reading ans asking.

The computer is a Texas Micro Systems and it runs the IDOS with MS-DOS. The Arcnet card is a Network Interface Corp (NCR90C146) and only one green led is blinking (always blinking even without the cable). When the PC starts, there is a single red blink then turns green.

I can see using the EDIT ARCNET.BAT that the Card Configuration is going on, but don't know if the card is working properly.

>I can see using the EDIT ARCNET.BAT that the Card
>Configuration is going on, but don't know if the card is
>working properly.

Okay, so it's an <I> operator interface, one provided by GE.

I'm not familiar with ARCNET.BAT; ARCNET.DDAT, but not ARCNET.BAT. Here's an ARCNET.DAT I was able to find:


;
; Configuration for ARCNET interface card. 06-SEP-1994
;
; This configuration file must match the hardware installed in the
; <I> processor. At startup time the <I> processor will look for
; this file as the F:\ARCNET.DAT file. (A template file is available
; in G:\DATA, copy it to F:\ARCNET.DAT and edit it there to match your
; hardware configuration.)
;
; This file contains 1 parameter per line. Any line not beginning
; with a recognized keyword is ignored. Any line containing
; invalid values for the given parameter are ignored (for example,
; specifying IRQ with a value > 15 or memory segment > 0FFFFH).
;
; Parameter lines may have leading/trailing blanks and tabs. Each
; line is case insensitive. Separate parameter keywords and their
; values with blanks and/or tabs. Each line must terminate with
; a <LF> character.
;
; The following are allowed parameter keywords:
; CONTROLLER <controller keyword>
; IRQ <decimal number, range 0-15>
; IO_BASE <hex number, range 0-FFFF>
; MEMORY_BASE <hex number, range 0-FFFF>
; MEMORY_SIZE <Size in Kbytes. Allowed values 8,4,2 or 1K>
; DIAGNOSTICS <ON | OFF> Used to enable duplicate node ID test.
;
; If CONTROLLER is specified, it should be specified first.
; Allowable <controller keyword>'s are:
; 9026 ==> 2K memory size, no buffer chaining, no diagnostics
; 90C26 Synonym for 9026
;
; 9098 ==> Buffer chaining, no diagnostics.
; 90C98 Synonym for 9098
;
; 90126 ==> Buffer chaining, diagnostics enabled.
; 90C126 Synonym for 90126
; 90198 Synonym for 90126
; 90C198 Synonym for 90126
;
; Unspecified parameters default to:
; CONTROLLER 90C198
; IRQ 15
; IO_BASE 2B0
; MEMORY_BASE D000
; MEMORY_SIZE 8K
; DIAGNOSTICS OFF
;
;--------------------------------------------------------------------------
;
; Configuration for NETWORK INTERFACE CORPORATION'S ARCNET controller
; card (PcARC-AT/20).
;
; CONTROLLER 90C198
; IRQ 15
; IO_BASE 2B0
; MEMORY_BASE D000
; MEMORY_SIZE 4K
; DIAGNOSTICS OFF
;
;--------------------------------------------------------------------------
;
; Configuration for CNET TECHNOLOGY INC.'S ARCNET controller card
; (CNT CN190SBT). These cards started shipping in early 1993.
;
; CONTROLLER 90C98
; IRQ 15
; IO_BASE 2A0
; MEMORY_BASE D000
; MEMORY_SIZE 8K
; DIAGNOSTICS OFF
;
;--------------------------------------------------------------------------
;
; Configuration for CONTEMPORARY CONTROL SYSTEM, INC's ARCNET controller
; card (PCA-CXS). These cards started shipping mid 1993.
;
CONTROLLER 90C198
IRQ 15
IO_BASE 2B0
MEMORY_BASE D000
MEMORY_SIZE 8K
DIAGNOSTICS ON
;

I don't recognize the card manufacturer you mentioned; I think that was the name/ID on the chip on some of the cards GE used, but the major manufacturers GE used were listed above in the ARCNET.DAT file.

I sympathize with your wish to know about the blinking LEDs. I don't really recall--it's been a LONG time. But, I seem to recall the RED LED blinked or was on solidly when there was a problem, and the green LED blinked when everything was okay OR it was searching for a Mark V panel.

Is the original AUTOEXEC.BAT and CONFIG.SYS re-installed on the computer?

I think there's a program (executable) you can run from the command line called ARCWHO.EXE which might be helpful. If you don't get any other "nodes" (devices--such as the Mark V) that might mean there is a cabling or connector problem. You can't usually just go out to any computer shop and buy an ARCnet BNC tee connector, or an ARCnet termination resistor--they are NOT the same as Ethernet BNC connectors and termination resistors.

Does the site have fiber optic cable in the StageLink between the <I> and Mark V? (There would be two "converters" to convert the coaxial cable signal to fiber and back from fiber to coaxial cable.) One or both of them might be the problem, OR the fiber might be broken.

You can buy ARCnet BNC connectors and cable (you might want to try running a new cable between the Mark V and the <I>--and if the <I> is in a "remote" control room from where the Mark V is located you might try taking the <I> to the Mark V location and using a shorter coaxial cable just to make sure it's NOT the cable. You should try RS for the ARCnet hardware and/or cable. They usually ship internationally and their prices aren't too awful. Sorry I don't remember the URL for their website, and this is the only one I could find with my web browser:

https://uk.rs-online.com/web/

Hope this helps!

Thanks...

I bought a new card, same brand but with a difference: I can only set IRQ from 1 to 7 and original IRQ assigned is 15.

I changed the ARCNET.DAT command to the same IRQ assigned with de dip switches but it didn't work. I can see the original card was a 16 bits, The new one is 8 bits, but don't know how that affects the communication.

About the ARCWHO command it searches nodes but doesn't find any nodes, the computer node should appear?